Web
Analytics Made Easy - Statcounter
JeffYoung - The Lotus Forums - Official Lotus Community Partner Jump to content


JeffYoung

Basic Account
  • Posts

    2
  • Joined

  • Last visited

More Info

  • Car
    1993 Lotus Esprit

JeffYoung's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I had the same problem. Turned out to be a slowly dying fuel pump.
  2. My 93 Esprit, after sitting for two weeks (don't ever do that again), started breaking up at higher (over 5k) rpm at full throttle. Symptoms and stats: 1. 93.5 SE, stock except for S4s chip and no cat exhaust. 2. Car hesitates dramatically above 5 k and misses, and bogs at full throttle at 4k or so and then backfires as if a cylinder is loading up wtih fuel, not firing and then igniting on the exhaust. 3. Car runs fine up to 3/4 throttle and 5k rpm. 4. After installing new chip, I've had an intermittent warm up issue. When first started cold, car will rev to 2k for about 2 minutes, then to 3k for 30 secnds and check engine light will come on. Revs will then drop to normal idle (1k) and check engine light goes off. 5. Car ran fine with exhaust and chip for about a month. 6. Pulled one plug and it was badly corroded. Have a new set on the way. Will try those first. If not, what's next: a. Coils? b. Coil packs? c. Ignitioin leads?
×
×
  • Create New...

Important Information

We use cookies to enhance your browsing experience, serve personalized ads or content, and analyze our traffic. By clicking " I Accept ", you consent to our use of cookies. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.