Web
Analytics Made Easy - Statcounter
Esprit radiator fans not working - Engine/Ancilliaries - The Lotus Forums - Official Lotus Community Partner Jump to content


IGNORED

Esprit radiator fans not working


esprit888

Recommended Posts

The issue is the radiator fans do not run (federal 94 S4 with A/C)  either at temperature (>92) or when the A/C is turned on (this may be misleading as its possible there is no R12 so the low-pressure switch may be stopping it from energizing?) Regardless they should work at temperature, so:
Checked all fuses and relay bases for heat damage/loose connections-all good 
Tried swapping relays, no difference.
Removed the AC request relay (I'm not sure if running in diagnostic mode energizes this one) The rear AC relay is in.
Jumped pins A-B on the ALDL connector, fans do not run with ignition off or on (also tried with AC request relay on and off) They should run in diag mode, but they don’t. Decided to take the sensor and ECM out of the equation first. 
Jumped Pins 30 to 87 on the front relay, fans run! This indicates an issue with the rear relay. Removed the rear relay and jumped pin 30 to 87, fans DID NOT run (checked for +12V at pin 30 - ignition on, +12v confirmed) Double checked fuse 13 and it was good. I then checked for continuity from pin 85 on the front relay to pin 87 on the back relay (pin 85 on the front relay gets its ‘fans on’ signal from pin 87 on the back relay) and did NOT get continuity (yellow line on attached pic). So, my question is what is there between pin 85 on the front relay to pin 87 on the back relay that is suspect? The wiring diagram shows two items, an RHC 12 ?? and an CBHC 2 ?? anyone know what these are? On the A/C circuit there appears to be a Zener diode but that should not stop it from running in temp mode. I then ran  +12v to the front relay (pin 85 with the relay installed) and it energized the relay and operated the fans, the perplexing issue though is that the fans do not run in either temp or A/C mode for the rear relays, but do run when jumpering 30 and 87 on the front relay. Anyone come across this gremlin?

Rad fan control070.jpg

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Moderator

You've done a good job diagnosing the problem! One more test you could do is check for continuity between pin 86 of the AC request relay (at the rear) and pin 85 of the rad fan relay (at the front). My guess would be a bad connection at pin 85 of the rad fan relay. If you do get continuity to the AC request relay, it could be the low pressure cut-off preventing the AC from working, and a problem in the wire from the ECM so the fans don't come on with temperature.

RHC = rear harness connector (located at the front A-pillar IIRC), CBHC = coil box harness connector (located on the RH fuel tank), the numbers indicate the cavity in the connector.

Greetz,

Filip

I have made many mistakes in my life. Buying a multiple Lotus is not one of them.

 

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Upgrade today to remove Google ads and support TLF.


×
×
  • Create New...

Important Information

We use cookies to enhance your browsing experience, serve personalized ads or content, and analyze our traffic. By clicking " I Accept ", you consent to our use of cookies. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.